Microsoft Word: Tables

Creating Tables

The two most important buttons on the Standard Toolbar for creating and using tables in Microsoft Word are **Tables and Borders** and **Insert Table**.

Insert Table Button

To use **Insert Table**, click on the button and drag across the white boxes. They will highlight across and down as you move. The bottom bar will tell you how many rows and columns you are creating as you go along. Click the mouse when you have reached your desired size.

In order to use this box to create a table larger than what is initially shown, click in a square and drag left and down from what is defined. Sizes will vary depending on the size of the paper and screen. As soon as you let go Word will create the table. The bottom bar shows how large the table is, if you move your mouse outside this selection box, the bottom bar will say **Cancel** and you can let go of the mouse without creating a table.

Insert Table through the Table Menu

To use the menu to insert a table, choose **Table** -> **Insert Table**. Set the number of columns and rows in the dialog box, and choose an AutoFit behavior:

- **Fixed column width**: will set the columns to always be a specific size in inches. Type or click the column width you want in the Auto box. If you leave it set to Auto, Word will insert columns of equal width between the margins.

- **AutoFit to contents**: will automatically adjust the width of the columns based on the amount of text that you enter.

- **AutoFit to window**: will resize the table so it fits within the designated area (usually the margins). This setting is specifically for creating web pages to adjust for varying web browser sizes, but works well for documents to keep the table within the window.

The **AutoFormat…** button allows you to use a preset format for your table. See the details of **Button 14** on the table toolbar worksheet.

Insert Table with Draw Table

A third way to insert the table is to click on the **Tables and Borders** toolbar button or choose **Draw Table** from the table menu. Either method will open the tables and borders toolbar, explained further on the next worksheet. This option also turns on a drawing tool (**`). The
mouse pointer will show as a pencil. When you click and drag the pencil across the page, it will draw a single celled table. You can then continue to draw in column and row walls with the pencil.

**Tables and Borders Toolbar**

When you click on the Tables and Borders button or you choose Draw Table from the Table menu you will get the following new toolbar:

(If you double click on the blue title bar of this toolbar, it will move it to the top of the window, below the formatting toolbar)

1. **Draw Table**: This first button will be active when this toolbar is opened. Your mouse arrow will appear as a pencil. This will allow you to draw cells. If you click and drag, it will draw a “box”, a one celled table. You can then use the pencil to draw other lines inside this cell. The line it draws will match the settings from buttons 3, 4, and 5. When you hold down the shift key on the keyboard the pencil turns into an eraser. The eraser can remove the cell walls.

2. **Eraser**: This button will change your mouse arrow to an eraser. The contact point is the little starburst at the bottom of the eraser. This eraser allows you to erase cell lines. (Sometimes this will only erase the line formatting if the cell wall is not supported). When you hold down the shift key on the keyboard the eraser turns into a pencil. The pencil can draw in cell walls.

3. **Line Style**: This drop down box allows you to choose different lines, such as single, double, and dashed.

4. **Line Weight**: This drop down box allows you to choose the thickness of your line.

5. **Border Color**: This button will let you choose the line color.

6. **Borders**: This drop down box allows you to pick which sides of the cell(s) you want to have a border, this is often easier than taking the pencil and clicking on each cell wall.

7. **Shading Color**: This drop down box allows you to pick colors for the background of the selected cell(s). More options are available through Format -> Borders and Shading…

8. **Insert Table Menu**: This drop down menu allows you to insert tables and/or parts of tables. (Options are shown here on right).

9. **Merge Cells**: This button is only active when more than one cell is selected. It will merge the selected cells into one cell. This option is often easier to use than the eraser, but it has the same effect, the selection of cells become one. Word puts all the information from the multiple cells into one cell separated by paragraph marks (enters).
10. **Split Cells**: This button will allow you to split the cell(s) into however many cells you designate. You will get a dialog box, asking how many columns and rows you want this cell to be split into. If you are trying to split a set of cells you will have the option to be able to merge the cells before split.

11. **Alignments**: This drop down box allows you to choose the cell alignments for your data. You can Left, Center and Right justify with the buttons on the formatting toolbar or by using their shortcut keys (Ctrl-L, Ctrl-E & Ctrl-R). But in order to be able to align along the Top, Middle and Bottom of the cell you must use this button. The default is Top, Left.

12. **Distribute Rows Evenly**: This button will make the selected rows equal height.

13. **Distribute Columns Evenly**: This button will make the selected columns equal width.

14. **Table AutoFormat**: This button will give you a choice of preset formats for your table.

15. **Change Text Direction**: This button will rotate the text in selected cells, first on the right side, then on the left, and back to normal. Text cannot be rotated upside down.

16. **Sort Ascending**: This button will sort the column that you are in, in ABC-123 order. Rows stay together. This action can be accessed through **Table, Sort…**. This option works for paragraphs as well as tables.

17. **Sort Descending**: This button is just like the **Sort Ascending** button but will sort the column that you are in, in ZYX-321 order.

18. **AutoSum**: This button will give you an automatic sum of the numbers directly above or directly to the left of the current cell. It will usually pick up the format of the numbers being summed. Simple mathematical formulas can be accessed through **Table, Formula…** option. Word is not made for complex mathematical functions, and does not always update these formula fields. If you change the numbers that are being calculated, right click on your formula and tell it to **Update Field**, or select the cell(s) and press F9 on the keyboard.
Math in Tables

Microsoft Word considers the cells of a table the same way Microsoft Excel does. Each horizontal row is numbered and each vertical column is lettered, such as the table shown here on the left. In Excel you can see the row and column headings. In Word, you cannot, you will have to count across and down to find the cell addresses.

*Microsoft Word is not Microsoft Excel.* You can do math in Word, however it is clumsy, it does not automatically update and gets easily confused when you merge or split cells. There is also no AutoFill feature in Word.

Mathematical Example:

<table>
<thead>
<tr>
<th>Name</th>
<th>Hourly PayRate</th>
<th>Hours Worked</th>
<th>Total Due</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jack</td>
<td>$15.00</td>
<td>40</td>
<td>$600.00</td>
</tr>
<tr>
<td>Jill</td>
<td>$18.00</td>
<td>30</td>
<td>$540.00</td>
</tr>
</tbody>
</table>

Grand Total: $1140.00

To put the first formula in for Jack’s Total, we first have to think about what our answer will be. For our Total Due for Jack (Row 2) we want the PayRate (Column B) times the number of Hours Worked (Column C). Jack's PayRate is cell B2 ($15.00) and his Hours Worked is cell C2 (40). Place your cursor in the cell where you want the answer (Cell D2). From the *Table* menu, choose *Formula…*. In the Formula box, type “=B2*C2”.

When you click ok, you will see $600.00. You can choose which format you would like from this Formula window, but in this case Word will automatically put dollar signs on the answer, because one of the numbers in the formula (from PayRate) have that format.

Repeat these steps until we have the total due for each person, and then we can use the *AutoSum* (Σ) button on the toolbar to find the *Grand Total*.

If you change any of the original data you will have to update each formula it will effect. To do this, right click on the formula field and choose *Update*, or highlight the cells and press F9.
Working with Large Tables

When a Word table begins to get too large, it is recommended that you place the data in Excel instead. So the natural question is, “What is too large?” The answer really depends on what you are working with, but as a general rule, I tend to place the data into excel when it begins to exceed one page.

If the table is part of a report it may not be practical to remove just that section. Here are some workaround for the funny things that may happen.

1. **DOUBLE ROW:** Sometimes with a table that goes across more than one page we see an echo row at the bottom of one page and the top of the next. This echo won't print, however it may confuse you. To avoid confusion, work on the table in normal view. \((\text{View} \rightarrow \text{Normal})\)

2. **SPLITTING TABLES:** If a table has gotten too large, or you wish to separate the data you can split it into two tables. Click in the row that you want to be the first row of the second table. From the Table menu, choose **Split Table.** This will place a blank line between the two rows, splitting the table into two separate tables. **TO REMOVE THE SPLIT**, delete the blank line between the tables.

3. **BREAKING ROWS ACROSS PAGES:** When your table gets to the end of the page, it will continue the row onto the next page, leaving part of the row on the first page. In order to "keep your rows together" such that they will not split across pages, choose **Table Properties** from the Table menu. On the Row tab, turn off the option to **Allow row to break across pages.**

4. **REPEATING HEADERS:** To repeat a row of text (the headers) of a large table across the top of each page. Click inside the row you want to repeat (usually the first row). From the Table menu, choose **Table Properties.** On the Row tab, click the check box in front of **Repeat as header row at the top of each page.**
Converting Tables to Text

Word allows you to convert text to tables and tables to text. This is a great formatting tool. I use it most often to be able to merge or split cells en masse. For example the table:

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Jack</td>
<td>Jacob</td>
</tr>
<tr>
<td>Jill</td>
<td>Jefferson</td>
</tr>
<tr>
<td>Jerry</td>
<td>Joker</td>
</tr>
</tbody>
</table>

In order to get the first and last names into separate cells we can convert this table to text and then convert the text back to a table. First place yourself inside the table and choose Table, Convert, Table to Text. Here you can choose how each cell will be separated. Rows will always be separated by paragraph marks, in the case shown above, since we only have one column it will not make a difference which separator we use. Our results will be:

Jack Jacob
Jill Jefferson
Jerry Joker

If we highlight our resulting lines, we can then turn our selection back into a table by choosing Table, Convert, Text to Table. If we choose Other: as our cell separator, and tell Word that our text is separated by spaces (by putting a space in the other box), when we click OK, each name goes in its own cell.

<table>
<thead>
<tr>
<th>Jack</th>
<th>Jacob</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jill</td>
<td>Jefferson</td>
</tr>
<tr>
<td>Jerry</td>
<td>Joker</td>
</tr>
</tbody>
</table>

The same process can be done in reverse. Where we can convert this table back to text, separating the cells with spaces by using the Other: option.

Notice in the Convert Text to Table window, there is an AutoFit behavior section.

**Fixed column width:** will set the columns to always be a specific size in inches. Type or click the column width you want in the Auto box. If you leave it set to Auto, Word will insert columns of equal width between the margins.

**AutoFit to contents:** will automatically adjust the width of the columns based on the amount of text that you enter.

**AutoFit to window:** will resize the table so it fits within the designated area (usually the margins). This setting is specifically for creating web pages to adjust for varying web browser sizes, but works well for documents to keep the table within the window.
Table inside Text

When you first insert a table, it often fills up the entire page, from left margin to right margin. There are many things we can do with the table to have it appear more comfortably on the screen.

1. **COLUMN WIDTHS:** Adjust the column widths to its content. You can do this by double clicking on the cell walls between the columns or by choosing **Table, AutoFit, AutoFit to Contents**.

2. **ALIGNMENTS:** Select the entire table and click on the Left, Center or Right align formatting buttons, or from the **Table** menu, choose **Table Properties**. On the Table Tab you can choose the **Alignment**. From this menu you can also left align, and set an **Indent**.

3. **WRAPPING TEXT:** If you want to have text running around your table you can set it by using Word's Point and Click feature. Place your mouse next to the table until you get the mouse cursor that shows something like [ ] and double click. Or you can choose **Table Properties** from the **Table** menu. On the **Table** tab set the Text Wrapping to **Around**. When the **Around** property is selected you will then be able to play with the **Positioning...** options.

![Table Properties](image1.png)

![Table Positioning](image2.png)